Jump to content
Bennyk

I have got a dks1710 minilab

Recommended Posts

I have got a dks1710 minilab, the circulation pumps are not turning, i have replaced the tank board the problem still not resolved. which means the problem was not the tank board. Now what can be the problem? 

Share this post


Link to post
Share on other sites

From what Benny has told me on the phone. Everything is working, tank are coming up to temp, prints are coming through the machine. When the any of the pumps are activated manually or automatically there is no response. I have not been to see the machine yet but this has me at a loss, base in mind I haven’t touched a machine in 10yrs. 

Share this post


Link to post
Share on other sites

I didn't know you could actuate the circulation pumps manually. We're talking about the circulation pumps and not the replenishment pumps. Correct?

Share this post


Link to post
Share on other sites

Benny,  I am talking about replenishment pumps, the machine is working pictures are good, there is no signal to turn the pumps on. Eight relays are not showing red  lights on to send message to pumps to tell them pump 20 times or 40 times. And there is power on pumps but no signal to communicate with pumps.

 

The first for relays works, they are for the heaters and agitating pumps

 

 please help

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...