Jump to content
Sign in to follow this  
Steven

Noritsu T15 film processor -replacing heater element

Recommended Posts

My Noritsu T15 film processor has started to blow the mains fuse (the shop fuse not inside the machine). 

I'm guessing a heater element has gone and short circuited??? I've disconnected the heaters from the main circuit board and the machine runs without popping fuses.

So, my question is...can anybody tell me how to get the heating elements out? I've removed a large screwed washer on top of the element but the element is underneath a large black plastic moulding which looks like it will lift off but I can't see how?!

Any help appreciated.

Share this post


Link to post
Share on other sites

I'm not sure what large screwed washer you are referring to? Possibly that's the float switch?

The heaters are the grey wires with the black rubber elbow on top, the heaters are just pushed into the tank, sometimes they can be difficult to get out due to scale.

Share this post


Link to post
Share on other sites

Thanks everyone for your expert advise. Dave S put me on the right track. I was indeed looking at the float switches not the heaters (I was having a bad day!!).

New heater now fitted and everything back up and running. Cleaned the float switches at the same time seeing as I had been fiddling with them!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...