Jump to content
Sign in to follow this  
bensioux

Frontier 500 turns off fuse in my shop

Recommended Posts

Hi, i've got a problem with Frontier 500. It's turning off my main fuse (which i have on the wall in my shop - only Frontier is connected to this fuse). When i am trying to turn it on it start to work after 5th, 6th time and after that everything is ok. When i'm coming to work fuse is off but Frontier is look like it's somwhere in the middle of warming up. Could it be some heater or sensor doing that or rather the problem is with my fuse or electric installation in my shop (it's only 5 years old).

Thank You 
Bartek

Share this post


Link to post
Share on other sites

In most cases it cause heater. Disconnect heaters and compare resistance. If one of them has different resistance it will be faulty. All heaters are the same - 200V 200W/240V 288W.

If resistance similar can be that heater has current leakage to ground. Try disconnect all heaters ( unplug heater connectors ) and turn on minilab. Of course chemicals will not heat, but you see your wall breaker will be disconnected, or not.

If wall breaker will not be disconnected then one by one connect heaters and allow to preheat tank. Look, which heater disconnect wall breaker.

If when connected one heater all heaters will not disconnect wall breaker then might be that wall breaker is bad and  disconnects, when it shouldn't be.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...