Jump to content

Kodak G3 Receipt printer


Jimbeen
 Share

Recommended Posts

Hello,

I've ran into many issues with the NII Printer_D receipt printer on the Kodak G3 Kiosk. However most of my problems have been with the Dip switch settings on the bottom or the printer itself or the COM settings in the Port Settings within Windows.

If you navigate to Printers and Faxes > Right Click > go to Properties > Select Ports tab > Select Configure Port.

The setting should be as follows...

Bits Per Sec: 38400

Data Bits: 8Parity: Odd

Flow Control: Xon/Xoff

The dip Switch Settings are as follows...

(Need to power off and unplug the serial cable prior)

On the bottom of the printer you will have Section 1 and Section 2

S1:

1=on

2=on

3=off

4=on

5=on

6=on

7=on

8=off

S2:

1=on

2=on

3=on

4=off

5=off

6=off

7=on

8=off

Then connect and power on kiosk.

If the printer constantly feeds or starts printing out ???? and other gibberish, try shitching Section 2, Switch 5 to on.

Make sure that the printer is selected as the default printer in windows and you should be set to go.

Hope that helps.

Link to comment
Share on other sites

hey drummrgod,

i followed all the steps uv outlined...

but it still refuses to be detected..

even in windows, when i try to print a test page, nothing comes out..

is it 3" paper?

and uses block/ line?

port is com 3, ive set up the rates as uv said.

do any other settings in the printer properties matter?

*it is on default too!

Thanks for your help!

Link to comment
Share on other sites

  • 2 weeks later...

does the receipt printer use a custom pin configuration,

connecting it using a normal serial cable to a serial port doesnt work,

and neither does a usb -> serial port converter

(windows cant even print a test page)

ill order in a pci serial card and see when i plug the original cable into the headers whether its the case..

Link to comment
Share on other sites

  • 7 months later...

I have just upgraded the motherboard on my G3, but now I can't get my serial reciept printer to work, it looks like my serial card (Lava quattro pci) won't install properly. I have tried drivers from the Lava site but I keep getting asked for an install utilities disk which I don't have. It worked fine before I changed my motherboard. Any suggestions please.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...