Jump to content

E2616 PS1,2 Tank Temp not rising


nash
 Share

Recommended Posts

Tried to check or replace the SSR5(for PS1 and PS2) on the PAC20 PCB on the backside of the F350 processor side. Usually SSR got damage oftenly causing the temperature not to rise. If u have the same rating of SSR you can replace it but you have to de-soldered the old one and solder the new one. I hope it will help you.Thank you!

Link to comment
Share on other sites

Verify temps manualy when it is acting up to be sure that the temp is actualu low. If the temps are truely low it could be the heater probe going bad. If they are not low it is the temp sensor acting up. Also verify that you have good circulation in the tanks. Try removing the filters temperarly and see if the problem continues.

Link to comment
Share on other sites

Have you checked if thermal switch on the heater is in open state (disconnect it and check with ohmmeter).

I usually do not service FUJI, but at one occasion When I was in the shop for KIS Photobook, customer had a problem with heating off the developer tank on Frontier 570, and when I took a look off what is happening, I found out that this thermal switch was off because there was bad circulation and heater was very hot, but customer just connected that two wires so that he can work normally.

I did not like that solution, but it worked.

On the end Fuji technician come into the shop (few days after), and problem was with the circulation, one washer was dropped somehow in the tube and circulation was bad.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...