Jump to content

Imagus IM1500 Scanner Fault


cecilh
 Share

Recommended Posts

Our Imagus IM1500 connected to our DKS 1530 kept saying on-screen the lamp was burnt out and to replace even though we could see it was lighting up.  On inspection it looks as if a connector has burnt out inside as per attached photograph.  

Would we need a new power unit or is there an easier solution?  To access this part it would look as if we'd have to strip the whole power unit out of the casing.

Any help would be appreciated.

Ben

Link to comment
Share on other sites

The problem is coming from too much heat when lamp cables are conected in first two brackets, there was (a long time ago in 2004) Tecnhnical Info which explain this and solution is to connect the lamp socket wires to the first and last bracket.

Now you have to pull out the power supply and put (solder) a new bracket instead off the burnt one, then you can test if it is still alive  :o

But to remove it, if I remember correctly you have to first pull out the filter unit  :-/

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...