Jump to content

DKS 1550 AGITATOR MOTORS


mike@focus23
 Share

Recommended Posts

Hi can any body shed light on this one, new DKS 1550 installed june/july 2006. In April 2007 new agitator motor fitted in stab tank one as it had stopped working. In October same problum on same motor, enginer fitted new washer, running again, now on sat 8/12 2007 stopped again. please note that i wash out stab tanks once a month, filters washed daily and changed weekly. ANY ONE ELSE HAD SIMULAR PROBLUM?

:(

Link to comment
Share on other sites

  • 4 weeks later...

Sometimes magnetic disc (pump turbine) needed to be changed, with time, diameter off the hole is getting bigger, and turbine is not turning smoothly.

Another reason is also that even if washer is changed, turbine was damaged (bottom is not flat, some concentric circles are formed).

Try to compare how big is the center hole on stab turbine against another one, and is the bottom smooth or there are some circles formed.

"white washer" frenchman?, usually is black.

Perica

Service Manager

Croatia

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...