Jump to content

Current exceed limit - Laser 340


Recommended Posts

I have the following problem. Frontier 340. 3 machines. One of the machines gives Blue laser current exceed limit. It gives it just on startup. When i hit OK the machine works fine. The laser is perfectly OK. When i put the same laser on different machine - the error does not apper. When i change the LDD board - the same. When i change the PC inside the machine - the same. I have no clue what could be. The only i havent change is the connection board with cables between the LDD and the Laser unit. Also the power supply but all the voltages are good and stabile.

The machine works fine. Blue laser temperature is 33C, PD 9uA and LD 75mA. Perfectly fine. Why only on startup and why only this machine.

Anyone had the same problem?

Link to comment
Share on other sites

Same laser unit on different machine is fine. Different laser on this machine - same problem. Same LDD on different machine - fine. Different LDD on this machine - error.

Same with the PC inside the machine.

Error appears only on startup.

laser exp.jpg

laser data.jpg

Link to comment
Share on other sites

It's seems like corrupted data somewhere and the error is keeped stored. 

Let the error appear and click OK. Print a photo to confirm it's OK and the error doesn't reappear. Them do a "G, B Laser (SHG) Optimal Temperature Setup." Post the result. 

Restart the printer and computer and test again. 


Link to comment
Share on other sites

If it was the laser EEPROM - the error would appear on different machine. If it was stored in the PC - it would have gone while changing the PC. Same with the LDD board. Where it could else be stored so it appear everytime i start the machine?

I run optimal temeperature many times till now. It is the same for more than a year.

I havent change the GMB, power supplies and the cables. Other than this error at startup the machine works perfectly fine. I've seen this in 2 more machines. Both other 2 machines has repaired blue laser guns.

Just thinking - if it was some hidden parameter in the EEPROM that was not changed during the repair the laser should give the same error on all machines. But it does it on only one.


Link to comment
Share on other sites

Just last week I had an ldd that came to repair with the same problem. Sometimes the problem only appears with a certain laser or ldd, or combination. 
I've seen this problem hundreds of times before (though mostly during repairing Lasers and LDDs for the Frontier 350 and 550/570). Although I haven't had time to investigate further, everything points to some data issue. I say this because at the exact moment the laser gun is started, the peak current momentarily exceeds the current limit (detereo or limit) for some reason (thats why you have that error) and then the current drops and stabilize. 
Seeing the laser values in the exposure check and knowing our test machine is working perfectly, I was sure that the problem was not with the laser guns. So it could just be incorrect data. 
Temporarily I change the eeprom values of the detereo and the limit current of the problematic laser gun (add more 50ma or more, doesn't matter) and restart the machine until it doesn't fire the error. Then, I do a  "G, B Laser (SHG) Optimal Temperature Setup.", to correct values. 
Then I restore the original values of the current (detereo and limit) and restart the machine. Problem is gone forever. 
I don't know if it's the same problem as yours, but try the procedure I told you. You changed everything except the laser current values.

Link to comment
Share on other sites

Ok. Thanks for the advise. I will try.

Something other that is on my mind is oxidation or some leakage in the PD cable between the laser unit and the LDD board. It is 10uA that is very small current. If there is some leakage it could easily achieve the overcurrent.

The other is some hidden parameter that is stored in the EEPROM but you cant access it from the menu. Some initial current that is different than the operational one. Most of the time i see the fault on repaired lasers. So it could be combination between some FW version on some of the boards in the machines and the data in the EEPROM. The LDD board is stupid. All the brain is in the LDA board. Or in the GMB. From the PC to the GMB is SCSI. Between the GMB and LDA is some propriatary cable with both paralel and serial interfaces but i never investigated what kind of commands and data goes between them. I was planning to connect a serial cable to the diagnostic port of the LDA board but i hadnt time to do it.

Have you ever done some reasearch on this topic?

Link to comment
Share on other sites

I don't remember at this point but I think there is a transimpedance amplifier on the laser gun control board, so that little PD current is amplified and converted to voltage before exiting the laser. Problems with leakage current is often encountered when I repair control or processing boards, such as the LDD23, GPA23, GEP23, GMB.... Etc... or on boards with fine pitched ics that came from machines with lack of maintenance and lots of dust and humidity.

I think the problem may not even be real, that is, the current does not even exceed the limit, and just be a problem with some flag in the eeprom of the laser gun that was written/activated by the firmware for some reason.

I didn't have time to investigate this further.
But it is possible that it is a problem of different firmware versions on the machine. Almost always forgotten, when replacing a control board it is essential to reinstall the machine's firmware, in order to ensure that the microcontrolers/microprocessors/Fpgas on the newly installed board have/run the same firmware version as all the machine's boards. Otherwise, strange things happen.

When a laser is repaired, it has to be tested and adjusted on a machine. It is possible that this test machine have a different firmware version than the client machine. Perhaps some firmware versions write different data or flags in the laser's eeprom to signal errors or so, which are later not correctly interpreted by other firmware versions, and then errors appear.
But.... This is speculation. We could only be sure by investigating. And it would even be very simple to confirm.
It is trivial to make the correlation between the eeprom data and the values that appear in the menu, since they are not encrypted. So it would be enough to dump the eeprom data to a computer, do the procedure I told you earlier and see if any value has been changed (those that do not appear in the menu), which could be some flag or error code. If, after the procedure, the machine does not show an error, we can put the original eeprom data back (the problematic one) and see if the error reappears. Then it's just testing with different firmware versions to see when and in what situations this field in the eeprom is written.

 I will look into it next time I have a laser with this problem to repair

Edited by Brohymn
Link to comment
Share on other sites

I think i have dumps and screenshots on one of my old laptops. 10-15 years ago i fixed some blue lasers on 340 and i was writing directly in the eeprom before i knew i could do everything on the machine.

And there is no amplifier inside the laser gun. On the LD there is just a HF generator that is modulating the diode. They do not use the internal PD in the diode at all. They use only external PD that is mounted after the lens.

The problematic machine is 500km away from me. In the summer i will go on holiday and i will take some equipment with me. This guy has 4 machines and whatever laser puts on this problematic machine - the error appears. He gave me his "problematic" laser last summer and i put it on a different machine and there was no error. I sent him the laser from the working machine and the error appears. He changed the LDD and LDA boards with no result.

As you said - it could be some flag in the EEPROM. As i remember the first time you put a laser from different machine the error do not appear. Just after the second restart . It needs more time for investigation. I have an adapter so i can easily read and write eeproms externaly. This is very good idea. I could do optimal temperature on this machine, after that on different, and after that again on this one and make dumps and screenshots before and after every operation. This will give good information what is going on.

I will change and the cabling and connector board between the LDD and the laser unit. I have one spare with me.

What is the procedure for flashing the boards?

Link to comment
Share on other sites

It's very rare for me to work with lasers and 340 pcb's, so I'm not very familiar with that machine and its electronic engineering design.

But from what we've discovered on the 550/570 series the problem seems exactly the same and certainly the problem is in the laser eeprom, assuming the Lda and ldd have already been replaced and the problem remains. 

We also use an external adapter to read and modify the eeprom values when necessary, which is much more practical. Eeprom dump before and after should reveal the problem for sure. I don't really believe it's the cabling otherwise you would have changed values, whether current, PD or temperature, and the values you show earlier seems correct, but nothing is lost trying... 

Not sure of the firmware update procedure for the 340, but it should be via FRONTIER 330/340 System (A1) Disk. You should check in the service manual

Edited by Brohymn
Link to comment
Share on other sites

The 550/570 lasers are quite reliable. We dont have many 500 series in my country. I fixed just some power supplies and a drive motor back in the years. Also the AOM Driver ofcourse. Had an issue with a green laser from 700 but it is nuritsu and all the adjustments are hardware. Didnt have much luck with it. Survived just few more months.

For more than 10 years i am away from the minilab bussines but i help some friends once or twice a year.

The 500 has laser diode blue. The 340 is DPSS and the fault is always the resonant cavity and the crystal itself. Back in the days i made a tooling for readjusting the resonant cavity and i am using a measurement microscope from old CTP printer to adjust the 340 lasers.

Now i have a burned red laser from 340. It is sitting and waiting but the owner have 2 spare laser modules and he dont ask for it. Till now i've seen many blue, 2 red and no green lasers defective from 340. Ever repaired 340 red laser? Any idea what to search for? Capacitor, LDO, the LD itself?

Link to comment
Share on other sites

500 and 550/570 lasers are not reliable. Faulty Red laser is typical problem there. Many times had to repair these Red laser heads.

On Fuji 7xxx and Noritsu QSS35xx PLUS, QSS37xx, QSS38xx typical fault is faulty G laser head. Had to repair many of them.
Latter on Noritsu minilabs this problem was fixed. All models with G at the end has direct modulation Green lasers and they have not AOM crystal.

On 330/340 usually faulty Blue laser head. First B laser temperature out of range then deteriorate is too big and finally doesn't start to work at all.

EPROMs are inside laser heads. So if laser unit is connected to other minilab  then EPROMs also connected there. If laser unit works on one minilab then it should work on other. If laser unit and LDD board work on other minilab imght be stored something wrong on computer software. Insert other HD, run recovery, install software, load backup and look what will be after that.

Some Fuji 340 had special laser unit, which was designed to work with special LDD model. Only once saw this set. Didn't test this laser with standard Fuji 340 LDD, so do not know it can work, or not.

Edited by Minilab service
Link to comment
Share on other sites

I am quite familiar with 340 blue lasers. I remove one of the mirrors and glue it again with the propper readjustments. 15 years since my first blue laser repair and it is still fine. Till now not a single repaired blue laser from 340 came back defective.

I changed the whole PC, not only the HDD. I had an issue on a different machine with bad sector on the HDD and it was not able to store the densitometer measurements. When you restart the machine the paper balance is way out. You make 2-3-4 tests and the machine works fine. You restart it and you have to redo the paper tests again. But this was fixed with new HDD and just a ghost disk to disk copy.

In the current case the LDD, LDA, laser module and PC are changed with no effect. All of them works fine on other machine. The things not changed are the power supplies, GMB and the connector board with cabling between LDD and laser unit.

Infact they work fine here. Just a overcurrent message appear during startup. Nothing more. I have no idea if some data is stored in the GMB. The Data download does not help.


P.S. If you have dead blue laser guns for 340 and you dont have tooling to fix them - i can help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...